Jump to content

Welcome, Guest!

Be a part of CinemaVision today! Once registered and logged in, you will have access to public chat and your own private messenger, you can view and contribute guides, collaborate on the forums, review downloads, give reputation to your fellow members, contribute content and so much more. Registering is quick and completely free, so what are you waiting for?
   Sign In    Sign Up

Become a RedCarpet Club Member Today!

   Join Now
Ragnarok

CinemaVision Add-on 0.0.30 Beta

Recommended Posts

The first CinemaVision Add-on Beta is up in the Downloads section of the site! Please test it out, and provide feedback. Don't forget to give us logs if you run into issues. Keep in mind, this isn't the finished build. There are some things that we're still working on. That said, it should be mostly functional. Enjoy!


View full record

Share this post


Link to post
Share on other sites

I have installed and enabled add on, however when choosing a content path it is not creating the desrination folders. Should i do this manually?  What are the folders Cinemavision is looking for? Thanks.

Edited by Dannyg
Update

Share this post


Link to post
Share on other sites

missing content path

missing content path in kodi cinema vision beta

since can't find content path unable to get file structure to place items to run cinema vision.  please help

Share this post


Link to post
Share on other sites

Created a clean setup of Isengard stable on a Windows10 desktop, made a copy of confluence skin and added button to DialogVideoInfo.xml (as mentioned in Kodi forum topic)

Tried to reproduce bugs found in previous versions and so far only found 1 (others seems to be gone), trailers keeps playing although it's disabled. (CV version used 0.0.29)

Attached are sequence and log file.

I also find the way of using CV not that user friendly. First you need to add items to queue and then you need to launch CV experience. I understand the queue thing if you want to see more then 1 movie but maybe a workaround or other argument when you only want to play 1 movie and launch CV experience in 1 click. (override play button would be a nice to have)

 

all-disabled.log

all-disabled.cvseq

Edited by schumi2004

Share this post


Link to post
Share on other sites

after downloading cinema vision beta the content path is not creating folder paths you indicate so i can find and use the preset resources that comes preloaded and since i cannot find these folders structures i am also not able to add resources to draw from.  using cinema experience i know where everything is after manually creating folder structure and placing them in cinema experience settings.  i very much like what i'm seeing and hearing so far with cinema vision but am stuck on this above issue.  please help please

 

Share this post


Link to post
Share on other sites

I have installed and enabled add on, however when choosing a content path it is not creating the desrination folders. Should i do this manually?  What are the folders Cinemavision is looking for? Thanks.

after downloading cinema vision beta the content path is not creating folder paths you indicate so i can find and use the preset resources that comes preloaded and since i cannot find these folders structures i am also not able to add resources to draw from.  using cinema experience i know where everything is after manually creating folder structure and placing them in cinema experience settings.  i very much like what i'm seeing and hearing so far with cinema vision but am stuck on this above issue.  please help please

 

So the way it works right now (and since it's in Beta we haven't finished instructions yet) is that you set your content path, then launch the add-on. Once you launch, it will create the directory structure. If you don't, it will run in Demo Mode. I might have our developer move that directory creation to when the content path is selected if we can, but that might be a limitation of Kodi. I'm not sure you can actually execute code from add-on configurations. Either way, you need to launch the add-on to scrape the content into our database for use with the add-on, or you can run that from settings as well.

Created a clean setup of Isengard stable on a Windows10 desktop, made a copy of confluence skin and added button to DialogVideoInfo.xml (as mentioned in Kodi forum topic)

Tried to reproduce bugs found in previous versions and so far only found 1 (others seems to be gone), trailers keeps playing although it's disabled. (CV version used 0.0.29)

Attached are sequence and log file.

I also find the way of using CV not that user friendly. First you need to add items to queue and then you need to launch CV experience. I understand the queue thing if you want to see more then 1 movie but maybe a workaround or other argument when you only want to play 1 movie and launch CV experience in 1 click. (override play button would be a nice to have)

 

all-disabled.log

all-disabled.cvseq

I'll pass this on to the developer - he was talking about it last night and appeared to have a fix for it, though. Thanks for the log and such, that's more helpful than you know.

Share this post


Link to post
Share on other sites

after i downloaded the program i tried to set content path i don't see anything related to cinemavision at content path do this download include the folder structure in content path or should i be looking for something else.   thanks for your help really new at this  

sorry what would the content path look like

Share this post


Link to post
Share on other sites

after i downloaded the program i tried to set content path i don't see anything related to cinemavision at content path do this download include the folder structure in content path or should i be looking for something else.   thanks for your help really new at this  

All you do is specify a root directory for CV to put all of its content directories. This can be any location. For my install, I created a directory called CinemaVision on C:\Kodi\, and pointed the default content path there.

Created a clean setup of Isengard stable on a Windows10 desktop, made a copy of confluence skin and added button to DialogVideoInfo.xml (as mentioned in Kodi forum topic)

Tried to reproduce bugs found in previous versions and so far only found 1 (others seems to be gone), trailers keeps playing although it's disabled. (CV version used 0.0.29)

Attached are sequence and log file.

I also find the way of using CV not that user friendly. First you need to add items to queue and then you need to launch CV experience. I understand the queue thing if you want to see more then 1 movie but maybe a workaround or other argument when you only want to play 1 movie and launch CV experience in 1 click. (override play button would be a nice to have)

 

all-disabled.log

all-disabled.cvseq

Try setting your default 2D sequence to use the CVSEQ that has it disabled. When launching from a skin, if that's not set, it'll default to the CinemaVision default sequence if that setting isn't set.

Share this post


Link to post
Share on other sites

Got it up running. Works incredible!! I have a feeling I'll be spending some time learning to create some really cool bumpers and scouring the web for slides and other content. Thanks Cinemavision Team!!!

Share this post


Link to post
Share on other sites

Try setting your default 2D sequence to use the CVSEQ that has it disabled. When launching from a skin, if that's not set, it'll default to the CinemaVision default sequence if that setting isn't set.

Okay, thanks for the tip. Will test it later and report back.

/edit:

Noticed when selecting default 2D CVSEQ I can browse local storage/folders but can't when saving any. When you want to save to local folder you need to create folder in Kodi filemanager that points to local storage/folder. Is that intentional?

all-disabled.log

all-disabled.cvseq

Edited by schumi2004

Share this post


Link to post
Share on other sites

Okay, thanks for the tip. Will test it later and report back.

/edit:

Noticed when selecting default 2D CVSEQ I can browse local storage/folders but can't when saving any. When you want to save to local folder you need to create folder in Kodi filemanager that points to local storage/folder. Is that intentional?

all-disabled.log

all-disabled.cvseq

It's not intentional, but there's no way for us to get around that. To avoid it, add the drive that you store your CinemaVision content as a source in the Kodi File Manager.

Share this post


Link to post
Share on other sites

Does this work on Amazon Fire TV Box?

Absolutely. You'll probably want to store the CinemaVision content on a network share somewhere, and your Home Automation support on Android platforms will be more limited, but it will work.

Share this post


Link to post
Share on other sites

still not getting it.  the path you created is it an empty folder and how do you get organized content in it.  I created path C:/users/Aaron/downloads/cinemavision but all i get is empty content, preloaded file structure or anything of the sort where i can put any downloaded content. don't mean to be a pain but what am i not understanding   thank you for your patience 

sorry no preloaded file structure of any sort where i can put downloaded content appears.  am i supposed to see file structure like cinema experience to be able to do this

Share this post


Link to post
Share on other sites

Created the top-level folder structure and pointed the CV to that file.

Ran "Install"

Nothing in the folder C:\Documents\Kodi\CinemaVision - no files, no sub-folders

Am I missing something?

Should I put at least one dummy file in the CV folder?

Thanks for your help - this is a wonderful app and I really want to get it up and running

John

Share this post


Link to post
Share on other sites

Answered my own question!

Yep ... sure missed something

After "install" be sure to press "update content" -- this will populate your directory with the correct sub-directories which can be populated with your media

Hope this helps

Share this post


Link to post
Share on other sites

Okay, tested first change in version 0.0.30 which is important for me and this is the result.

[- 0.0.30 -]
- add:    When the experience is run with no queue, it uses the selected item

It indeed directly starts and shows movie in queue as with original procedure, it starts playing audio format bumper (the only one enabled in sequence) but didn't play movie afterwards. Maybe i did something wrong not sure.

Note: Did not start from scratch since i expected minimal impact on the DB's and settings. Will do a clean setup later today.

Test.cvseq

run-without-queue.log

settings.xml

Share this post


Link to post
Share on other sites

i figured it out how to populate folders so that i can put in and retrieve items in cinemavision thanks for your help it is invaluable.  however i do an issue on how to correctly set up slides folder so that it populates items i want to place in cinemavision.  for instance under the main slides folder i have sub folders categorized by  folder name i.e. frame by frame, critics corner, blockbusters etc but when i go to retrieve items in cinemavision i don't see any of the files.  what am i doing wrong.  thanks for your help in advance

Share this post


Link to post
Share on other sites

Okay, tested first change in version 0.0.30 which is important for me and this is the result.

[- 0.0.30 -]
- add:    When the experience is run with no queue, it uses the selected item

It indeed directly starts and shows movie in queue as with original procedure, it starts playing audio format bumper (the only one enabled in sequence) but didn't play movie afterwards. Maybe i did something wrong not sure.

Note: Did not start from scratch since i expected minimal impact on the DB's and settings. Will do a clean setup later today.

Test.cvseq

run-without-queue.log

settings.xml

We're still working some things out. For some reason, I couldn't view your log as an attachment. When you post up logs, try to use Pastebin or the log uploader, it makes them easier to read. :D

Hi so far so good lol, but can we not add rating bumper videos yet, can't seem to see that option when adding a video bumper? cheers

Our developer has been working on the Ratings Bumpers today, changing the whole way it works. What is there now was really just a placeholder to test functionality. 

i figured it out how to populate folders so that i can put in and retrieve items in cinemavision thanks for your help it is invaluable.  however i do an issue on how to correctly set up slides folder so that it populates items i want to place in cinemavision.  for instance under the main slides folder i have sub folders categorized by  folder name i.e. frame by frame, critics corner, blockbusters etc but when i go to retrieve items in cinemavision i don't see any of the files.  what am i doing wrong.  thanks for your help in advance

The Trivia Slides can only be one level deep in the Trivia Slides folder. Make sure you remove all URL and XML files from those directories, then CV will just play the files. There isn't any configuration as far as selecting individual slides to play. Here's an example of how it should look:

Trivia Slides
    |- Frame By Frame
        |- 300_a.jpg
        |- 300_q.jpg
    |- Blockbusters
        |- 1985.jpg
        |- 2008.jpg

If you go more than one directory deep in Trivia Slides, CinemaVision currently ignores those directories.

Share this post


Link to post
Share on other sites

Hey Hey got it working for trivia slides! At least now I know my naming conventions work. Props for Ragnarok for an incredible job seeing this add-on through and his commitment supporting it. Now I just need to trash the RGB TV so I can actually use it :P

Share this post


Link to post
Share on other sites

The .30 beta is working pretty well. I may have found a couple of bugs that'll need to be addressed.

1. I moved a number of slides around in the trivia folder and did a refresh. Once in awhile I'll now notice a black screen during the slide portion. Does a refresh also let CinemaVision know that files have been moved/deleted or does a refresh only add new files? I'm thinking that when CinemaVision doesn't find a slide where it used to be it'll just display a blank black screen until the next slide.

2. I am unable to change the selection for the Trivia Intro after changing Random to "No" and selecting a specific video. I've included another video bumper in the directory and refreshed everything, but when I attempt to select a different video nothing happens. This may also be true for other non-random selections.

Share this post


Link to post
Share on other sites

thank u 4 the awesome work u put into this program. i would like to kno is it possible to use movie quiz program in cinemavision like in cinema experience and if so how can it be infused within cinemavision 

Share this post


Link to post
Share on other sites

thank u 4 the awesome work u put into this program. i would like to kno is it possible to use movie quiz program in cinemavision like in cinema experience and if so how can it be infused within cinemavision 

Movie Quiz hasn't been updated in a long, long time. For that reason, we can't include it right now. In the future, we may have our own version of Movie Quiz that's tied to all of the CinemaVision movie trivia and games in our databases. Stay tuned!

can u please give instructions on how to add a new folder to cinemavision sequence so that it shows in the line up if this is possible

Sure thing! Create a new Video Bumper Module, then for Type, choose Directory, and browse to the directory of your choice. Then all you do is set whatever settings you want in the Module. You can then rename the module to reflect the name of your directory.

Share this post


Link to post
Share on other sites

thank u for the instructions however i am not sure how or where to go to in order to create new bumper module. when i try to use the directory for anything in cinemavision like add new bumper then i choose directory it only gives me choices of addons downloaded within my file manager (i.e xunity, tvaddons, total tv, ect) nothing that i added in the file structure i can find  

Share this post


Link to post
Share on other sites

hi, just checking to see if possible for u to give me instructions on how or where to go to create new bumper module and how i can access new file in the directory. the directory as of now only opens up to kodi main directory root that does not include any files of cinemavision.  everything else still running well after downloading cinemavision updates it only gets better .  thanks for ur help in advance

Share this post


Link to post
Share on other sites

Sorry about that, got sidetracked with the new version. There's a video here that shows where to go to create a new module. Start watching at about 3:30. You put your cursor on an empty spot in the sequence, between two modules, and scroll down to Add Video Bumper. Once you have it created, use Directory instead of Content to use a specific directory, or Single File to browse to a specific file to use.

Edited by Ragnarok

Share this post


Link to post
Share on other sites

About Us

CinemaVision began in 2014 as a collaboration to create content for use with your home theater, offering movie trivia slides and video bumpers. It has since grown to be THE PREMIER WAY to create and customize your preshow experience. Download the CinemaVision add-on for Kodi today from the official Kodi repository, and easily create a sequence of trivia, videos, trailers, home automation triggers and more that will bring the experience of a movie theater straight to your screen!

×

Important Information

By using this site, you agree to our Guidelines and Terms of Use.