Jump to content

Welcome, Guest!

Be a part of CinemaVision today! Once registered and logged in, you will have access to public chat and your own private messenger, you can view and contribute guides, collaborate on the forums, review downloads, give reputation to your fellow members, contribute content and so much more. Registering is quick and completely free, so what are you waiting for?
   Sign In    Sign Up

Become a RedCarpet Club Member Today!

   Join Now
  • 0
Luap

Action not executing whole shell scripts

Question

Hey everybody, 

I just spend 3hours trying to figure this out, but I couldn't do it, so maybe you can help! :)

My goal is to have an action that via the Harmony Hub changes my receivers source. I use https://github.com/sushilks/harmonyHubCLI to connect to the Hub and it works great.

So as you can see in my .cvaction I call a shell script, that part works. However what does not work is the whole execution of the shell script. As you can see I'm executing a nodejs script within the shell file, this works like a charm when testing it through ssh. The output of the node script gets logged and more importantly the receiver source is being changed. However when calling the shell script using the action file it does create the log file but only prints "Executed", it does not print the output of the "node harmony....." command. Furthermore it does not result in the receiver changing the source. Since the command does not even get logged, not even an error message, I have concluded that it is not being executed. But why?

 

Any help would be greatly appreciated,

Paul

 

Edit: I also tried using a python script with the library "Naked" to execute the node script. Again it worked when doing it through ssh but no result when doing it through the actions.

Edit 2: It appears to not even be executing "default" linux commands like mkdir. Once again, when running the script through ssh it creates the folder, but when doing it through actions it does not. However it does update the log file so the sh script is being partially executed.

switch.cvaction

switch.sh

Edited by Luap

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

About Us

CinemaVision began in 2014 as a collaboration to create content for use with your home theater, offering movie trivia slides and video bumpers. It has since grown to be THE PREMIER WAY to create and customize your preshow experience. Download the CinemaVision add-on for Kodi today from the official Kodi repository, and easily create a sequence of trivia, videos, trailers, home automation triggers and more that will bring the experience of a movie theater straight to your screen!

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines and Terms of Use.