Jump to content

Welcome, Guest!

Be a part of CinemaVision today! Once registered and logged in, you will have access to public chat and your own private messenger, you can view and contribute guides, collaborate on the forums, review downloads, give reputation to your fellow members, contribute content and so much more. Registering is quick and completely free, so what are you waiting for?
   Sign In    Sign Up

Become a RedCarpet Club Member Today!

   Join Now
  • 0

Wanna Play a Movie


I'm hoping this is a forum to help complete novices. I need to play a film (movie). I have a custom built cinema at home and have just been introduced to CinemaVision and i am amazed how simple it is for a thicko like me to set up. I have an introduction to my cinema, followed by a Pearl & Dean intro, random choice of 3 cinema adverts (from a file containing 200), ice cream and soft drinks adds, then a coming soon to Screen 9 intro, 3 trailers, switch off your mobiles and then NOTHING when i play from the add on. When I play the movie (film) in the Back Row kodi skin CinemaVision doesn't work at all, simply goes straight to the film (does work in Cinema Experience). I have spent hours trying to get this to work - P:LEASE help!

Share this post

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Okay, I think CV should be compatible since Kodi 14.  So everything is playing fine with exception of your feature module using the default Kodi skin and launcher?  The reason I ask is because you mentioned CV doesn't work at all with the Back Row skin, which I'm not familiar with.  My suggestion would be try to get it working with the default skin first, then try and transition to another.  It may not be supported by a particular skin.

Share this post

Link to post
Share on other sites
  • 0

Thanks OTA. But I've tried various skins, including the Kodi default - nothing! Perhaps I'm doing something wrong? Like I said, wen I click on "play" in CinemaVision, my whole sequence works and when the sequence gets to the Feature (F), the CinemaVision default page is displayed followed by the rest of my sequence (walk out video clip); it works perfect every time!

Share this post

Link to post
Share on other sites
  • 0

Sorry about the wait.  Had computer issues.  So I compared your log to mine after turning on debug mode.  My first suggestion would be to remove any add-ons that may be giving you a problem.  I noticed this, but is likely not what's causing the playback issue with CV.  You may want to consider uninstalling Kodi and installing it fresh just to make sure it runs clean natively.

22:03:29 T:1656   ERROR: EXCEPTION: argument "path" for method "XBMCAddon::xbmcvfs::exists" must be unicode or str
22:03:29 T:1656   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.TypeError'>
                                            Error Contents: argument "path" for method "XBMCAddon::xbmcvfs::exists" must be unicode or str
                                            Traceback (most recent call last):
                                              File "C:\Users\Denis Strickland\AppData\Roaming\Kodi\addons\script.common.plugin.cache\default.py", line 40, in <module>
                                              File "C:\Users\Denis Strickland\AppData\Roaming\Kodi\addons\script.common.plugin.cache\default.py", line 35, in run
                                              File "C:\Users\Denis Strickland\AppData\Roaming\Kodi\addons\script.common.plugin.cache/lib\StorageServer.py", line 263, in run
                                                if self.xbmcvfs.exists(self.socket):
                                            TypeError: argument "path" for method "XBMCAddon::xbmcvfs::exists" must be unicode or str
                                            -->End of Python script error report<--

I can't really tell what you were trying to watch from the logs, so I picked the last thing it looked like you were trying to watch.  At first I thought it may have been the file name giving CV an issue, but it looks like you've tried other movies without brackets, etc.  I can't honestly see where the issue is.  I've posed up an example of what mine looks like for comparison, but I'm running a newer version of Kodi on a different OS so I'm not sure how helpful it will be.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Guidelines and Terms of Use.