Jump to content

Welcome, Guest!

Be a part of CinemaVision today! Once registered and logged in, you will have access to public chat and your own private messenger, you can view and contribute guides, collaborate on the forums, review downloads, give reputation to your fellow members, contribute content and so much more. Registering is quick and completely free, so what are you waiting for?
   Sign In    Sign Up

Become a RedCarpet Club Member Today!

   Join Now
  • 0
biohazardx9

Bug in CV 1.1.1a10 - conditions

Question

Hi all

CV working fine except one small thing...

so I have a custom sequence for example, I've programmed it in, and it plays nice in the editor.
I have tagged it to run say for example on BBFC:18 and Romantic.

I launch CV via context menu and the playlist/queue appears having selected the right sequence. If I choose play, it crashes. (but only on that sequence default is ok),
now if I were to do the same again but instead of hitting play, I go to select a sequence and choose the same one again then press play it will work. (example it picked romantic.sequence automatically based on tags, then I go to choose a sequence and choose romantic.sequence again) 

attached is my log.

2020-09-21 01:04:09.587 T:140635257648896   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <class 'lib.cinemavision.exceptions.EmptySequenceFileException'>
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/script.cinemavision/addon.py", line 18, in <module>
                                                player.begin(args=args)
                                              File "/storage/.kodi/addons/script.cinemavision/lib/player.py", line 80, in begin
                                                e.start(seqPath)
                                              File "/storage/.kodi/addons/script.cinemavision/lib/experience.py", line 953, in start
                                                return self._start(sequence_path)
                                              File "/storage/.kodi/addons/script.cinemavision/lib/experience.py", line 965, in _start
                                                self.processor = cinemavision.sequenceprocessor.SequenceProcessor(sequence_path, content_path=cvutil.getContentPath())
                                              File "/storage/.kodi/addons/script.cinemavision/lib/cinemavision/sequenceprocessor.py", line 1251, in __init__
                                                self.loadSequence(sequence_path)
                                              File "/storage/.kodi/addons/script.cinemavision/lib/cinemavision/sequenceprocessor.py", line 1345, in loadSequence
                                                self.sequence = sequence.loadSequence(sequence_path)
                                              File "/storage/.kodi/addons/script.cinemavision/lib/cinemavision/sequence.py", line 1385, in loadSequence
                                                return SequenceData.load(path)
                                              File "/storage/.kodi/addons/script.cinemavision/lib/cinemavision/sequence.py", line 227, in load
                                                raise exceptions.EmptySequenceFileException()
                                            EmptySequenceFileException
                                            -->End of Python script error report<--

 

Running Libreelec 9.2 X86_64 (Based on Kodi 18.8)

Much appreciated for the help, I know there is a 1.1.1a12 but I can't find it anywhere to get hold of...

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Same again. No different, it is very odd!

 

I'll try another sequence incase ive done something.

 

Fixed it now - unsure what it was but i redone the sequence by 'cloning' the default....

  1. load default into editor
  2. change its name
  3. save as using a different name
  4. edit said file with content.
  5. save.

the only thing I did differently was previously I made a new file....

I can live with the quirk.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Aha!

 

I may have found the actual bug! - well I donr another script... same error... but I did think (being I work in IT) that perhaps the PATH is too long? so yes my script had a longer name than the others.... I shortened it and guess what?

bug went away :) and it played.

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

About Us

CinemaVision began in 2014 as a collaboration to create content for use with your home theater, offering movie trivia slides and video bumpers. It has since grown to be THE PREMIER WAY to create and customize your preshow experience. Download the CinemaVision add-on for Kodi today from the official Kodi repository, and easily create a sequence of trivia, videos, trailers, home automation triggers and more that will bring the experience of a movie theater straight to your screen!

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines and Terms of Use.