Jump to content

Welcome, Guest!

Be a part of CinemaVision today! Once registered and logged in, you will have access to public chat and your own private messenger, you can view and contribute guides, collaborate on the forums, review downloads, give reputation to your fellow members, contribute content and so much more. Registering is quick and completely free, so what are you waiting for?
   Sign In    Sign Up

Become a RedCarpet Club Member Today!

   Join Now

Audio bumper recognition

Recommended Posts


when i start an atmos or dtsx file, no audio-bumper or only the setted fallback is playing.

I have Kodi 18.9 with the newest CV version installed. My atmos and dtsx files have this flags in the filename like titel.atmos.ext. Kodi recognize the files correctly and CV shows in the qeue-windows TRUE HD+ATMOS as audio format. All files are in the corret folders. This happend after the update to the newest version. In my older installation with kodi 17x and CV from repository it worked. 

Any ideas?


Share this post

Link to post
Share on other sites

Hi, sorry for my late reply... with newest i mean the latest one from this site "Kodi 18+".  

Here some parts of the logfile:


2021-05-17 20:29:46.219 T:3648426864  NOTICE: [- CinemaVision -] (API): [AudioFormatBumper] Method: af.detect Fallback: af.format Format: DTS-X
2021-05-17 20:29:46.219 T:3648426864  NOTICE: [- CinemaVision -] (API):     - Detect
2021-05-17 20:29:46.220 T:3648426864  NOTICE: [- CinemaVision -] (API):     - Detect: Looked at the file path u'Deepwater Horizon.Atmos.mkv' and decided to keep audio format None
2021-05-17 20:29:46.220 T:3648426864  NOTICE: [- CinemaVision -] (API):     - No feature audio format!
2021-05-17 20:29:46.220 T:3648426864  NOTICE: [- CinemaVision -] (API):     - Format
2021-05-17 20:29:46.224 T:3648426864  NOTICE: [- CinemaVision -] (API):     - Format: Using bumper based on setting (u'Deepwater Horizon')
2021-05-17 20:29:46.260 T:3648426864  NOTICE: [- CinemaVision -] (API): [Feature] x 1
2021-05-17 20:29:46.287 T:3648426864  NOTICE: [- CinemaVision -] (API): Sequence processing finished


2021-05-17 20:31:25.579 T:3648426864  NOTICE: [- CinemaVision -]: Experience: Playing next item: FEATURE [ Deepwater Horizon ]:
                                                Path: smb:// Horizon (2016)/Deepwater Horizon.Atmos.mkv
                                                Year: 2016
                                                Studios: Closest to the Hole Productions, Di Bonaventura Pictures, Summit Entertainment, TIK Film
                                                Directors: Peter Berg
                                                Cast: Mark Wahlberg, Kurt Russell, John Malkovich, Gina Rodriguez, Dylan O'Brien, Kate Hudson, J.D. Evermore, Ethan Suplee, David Maldonado, Henry Frost, Jeremy Sande, Brad Leland, Sue-Lynn Ansari, Douglas M. Griffin, Joe Chrest, James DuMont, Chris Ashworth, Rob Steinberg, Peter Berg, Anthony 'Ace' Thomas, Stella Allen
                                                Genres: Action, Drama
                                                3D: No
                                                Audio: None

Let me know if you need more from logs. For me i correctly named the file and kodi recognize it as atmos. Cinemavision qeue shows up DolbyTrueHD+Atmos. Log says not detected.

Share this post

Link to post
Share on other sites

Your logs are truncated so it doesn't report what version of CV you are running.  Below is a link to the latest version.


Have you tried a movie with HD audio other than Atmos?  Just wanting to determine if you are just trying to get Atmos to work or if it's not working at all.  Looks like you have fallback to DTS-X?  Do you have anything in the DTS-X directory?

Share this post

Link to post
Share on other sites

I use the same version (1.1.1).  Everything except DTS-X and ATMOS seems to be detected fine. The log shows the detection of all other formats like DD+. The fallback was a test, but it doesnt matter what is set as fallback. It seems that even the atmos/dtsx string/flag in the filename isnt recognized properly. 

Tried to set the type of all action to 2D like i read in an other post but without luck.

Share this post

Link to post
Share on other sites

Did anybody get this to work? I been tussling with this for a while. So I created a sequence with just audio bumper module and feature. I played a Dolby Atmos movie with the sequence and it still gave me the Dolby TrueHD video? I have atmos in the filename and the atmos track is the only audio track. What could possibly be wrong?

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Guidelines and Terms of Use.