Jump to content

Welcome, Guest!

Be a part of CinemaVision today! Once registered and logged in, you will have access to public chat and your own private messenger, you can view and contribute guides, collaborate on the forums, review downloads, give reputation to your fellow members, contribute content and so much more. Registering is quick and completely free, so what are you waiting for?
   Sign In    Sign Up

Become a RedCarpet Club Member Today!

   Join Now
  • 0
noiprocks

stuck@0.0.43 Beta and "hue actions" question

Question

Hey,

@first: AWESOME plugin you're developing. It's absoulutely great and a pleasure to use :D

Now some specs before I start describing my problem:

System: Amazon Fire TV 1st gen / Android
Kodi: Kodi 15.2 Isengard RC 3

Now my problems/questions are the following:

Problem1 ( noip.cvseq)

I've set up a nicely working sequence with some actions that trigger some hue light dimmings.
This sequence works like a charm, as long as I stay on 0.0.43.

As soon as I uprgrade to a newer version - tested 0.0.44 up to 0.0.46 - my sequence doesnt work
any longer. If I hit play, the screens gets black as if the sequence is starting, but nothing happens.
I manually have to hit stop to return from the black screen to the editor.

I've tested to set up a new sequence when +0.0.43 with e.g. only the "courtesy element", which works. But as soon as i add
additonal modules everthing stays black. Even redbuild my whole sequence from scratch after installing a version
thats + 0.0.43 but that didnt work either.

Problem2 (noip v02.cvseq)

I was/am using the Kodi.Hue.ambilight addon in general. As this addons of course interfers with the hue-actions I embedded in my sequenecs
I was happy when I stumbled upon the possibility in another thread to "disable" the addon at the beginning of a sequence and automatically
re-enable it via an action at the end or when aborting a sequence manually .

But somehow this doenst work. The Kodi.Hue ambilight addon stays active despite the action at the beginning of the sequence to disable it. To be more specific, when I start my sequence with the action to disable the addon, the screen stays black and nothing happens...

Could this be a problem due to the fact that my sequence starts with two consecutive actions?

 

General Hue-Question

I've set up some actions for my hue lights like trailer-lights, feature-lights, etc.
Additionally i've set up and defined actions for my hue lights under the general settings for e.g. pausing a sequence.

Now my question is: is there some way to define that the hue lights return to the light-setting/action in correspondence
to what moment of time i was in my sequence when i hit pause?

E.g. I'm watching trailers -> then i hit pause -> i trigger the "Hue-TestPause" action -> I resume to the sequence -> I return to the "Hue-TestTrailerLights" setting ?

Up to now its "only" possible to define a/one general action when resuming a sequence under the general plugin-configuration. But this of course doesn't take into account at what "hue-moment" (e.g.Trivia,Feature,Trailer) I was when I hit pause.

Could this be done with a "command module" ? Any tips appreciated ;)

 



My sequence and my actions are attached if that might help.
Let me know if you need further informations like e.g. a log.

noip v02.cvseq

Actions.zip

noip.cvseq

Share this post


Link to post
Share on other sites

27 answers to this question

Recommended Posts

  • 0

PS

 

script.xbmc.hue.ambilight-master   i think my kodi hue addon is called? i found it in my local/roaming/kodi/addons

is it another program? is it still same files needed?

 

i think i dl it here

https://github.com/cees-elzinga/script.xbmc.hue.ambilight

 

Ahhh...I think we found your problem :)

The action file can't work at all, as it's disabling an addon you don't have installed *hehe*


I was assuming you were already using this newer ambilight addon. But you're still using the older one.

So all you have to do is to change the "
script.kodi.hue.ambilight"-part in the cv-action with "script.xbmc.hue.ambilight".

This will send the correct command for disabling the addon you are actually using ;)

Edited by noiprocks

Share this post


Link to post
Share on other sites
  • 0

Hey,

@first: AWESOME plugin you're developing. It's absoulutely great and a pleasure to use :D

Now some specs before I start describing my problem:

System: Amazon Fire TV 1st gen / Android
Kodi: Kodi 15.2 Isengard RC 3

Now my problems/questions are the following:

Problem1 ( noip.cvseq)

I've set up a nicely working sequence with some actions that trigger some hue light dimmings.
This sequence works like a charm, as long as I stay on 0.0.43.

As soon as I uprgrade to a newer version - tested 0.0.44 up to 0.0.46 - my sequence doesnt work
any longer. If I hit play, the screens gets black as if the sequence is starting, but nothing happens.
I manually have to hit stop to return from the black screen to the editor.

I've tested to set up a new sequence when +0.0.43 with e.g. only the "courtesy element", which works. But as soon as i add
additonal modules everthing stays black. Even redbuild my whole sequence from scratch after installing a version
thats + 0.0.43 but that didnt work either.

Problem2 (noip v02.cvseq)

I was/am using the Kodi.Hue.ambilight addon in general. As this addons of course interfers with the hue-actions I embedded in my sequenecs
I was happy when I stumbled upon the possibility in another thread to "disable" the addon at the beginning of a sequence and automatically
re-enable it via an action at the end or when aborting a sequence manually .

But somehow this doenst work. The Kodi.Hue ambilight addon stays active despite the action at the beginning of the sequence to disable it. To be more specific, when I start my sequence with the action to disable the addon, the screen stays black and nothing happens...

Could this be a problem due to the fact that my sequence starts with two consecutive actions?

General Hue-Question

I've set up some actions for my hue lights like trailer-lights, feature-lights, etc.
Additionally i've set up and defined actions for my hue lights under the general settings for e.g. pausing a sequence.

Now my question is: is there some way to define that the hue lights return to the light-setting/action in correspondence
to what moment of time i was in my sequence when i hit pause?

E.g. I'm watching trailers -> then i hit pause -> i trigger the "Hue-TestPause" action -> I resume to the sequence -> I return to the "Hue-TestTrailerLights" setting ?

Up to now its "only" possible to define a/one general action when resuming a sequence under the general plugin-configuration. But this of course doesn't take into account at what "hue-moment" (e.g.Trivia,Feature,Trailer) I was when I hit pause.

Could this be done with a "command module" ? Any tips appreciated ;)


My sequence and my actions are attached if that might help.
Let me know if you need further informations like e.g. a log.

noip v02.cvseq

Actions.zip

noip.cvseq

Hey, thanks! We're pretty proud of it.

Problem 1: Yeah, that's our bad. We broke Action modules, apparently. I'm about to upload version 0.0.47 which we think fixes the issues with actions and black screens.

Problem 2: It should be working with two consecutive Action Modules, but you shouldn't have to split up your actions like that. All you're doing is adding processing time. You can create one action file with any number of actions in it. I'd start there, and create an action file that first disables the Hue add-on, then sets whatever scene you want to set.

General Hue Questions: There's not, currently. I don't know why that didn't occur to us. I guess we always assumed people would only ever pause their feature, and could just set up that Resume action to be the same as their Feature scene settings. I'll talk to our developer and see what we can do about that. We could potentially eliminate the resume action and store the previous action, as you suggested, and run that instead.

Share this post


Link to post
Share on other sites
  • 0

i also have trouble with the separate hue ambilight addon. how do i enable and disable it in a sequence? question to threadcreator as it seems he has some insights. 

i want ambilight feature on during short movies and trivia. then regular hue actions (low deep red for trailers) and lights of for main feature.

Edited by Rippmaster

Share this post


Link to post
Share on other sites
  • 0

Hey, thanks! We're pretty proud of it.

Problem 1: Yeah, that's our bad. We broke Action modules, apparently. I'm about to upload version 0.0.47 which we think fixes the issues with actions and black screens.

Problem 2: It should be working with two consecutive Action Modules, but you shouldn't have to split up your actions like that. All you're doing is adding processing time. You can create one action file with any number of actions in it. I'd start there, and create an action file that first disables the Hue add-on, then sets whatever scene you want to set.

General Hue Questions: There's not, currently. I don't know why that didn't occur to us. I guess we always assumed people would only ever pause their feature, and could just set up that Resume action to be the same as their Feature scene settings. I'll talk to our developer and see what we can do about that. We could potentially eliminate the resume action and store the previous action, as you suggested, and run that instead.

Problem 1: Already installed 0.0.47 and it's working again. Thanks mate :D

Problem 2: Thanks for that tip. I'll give it a try and use your updated/fixed action files ( here.) as a base.

General Hue Questions: No need to hurry, it might as well be that I'm kind of picky and that this scenario ain't what a typical user might need. Nevertheless I'm of course happy to hear that you don't brush it aside and consider implementing it.

 

 

 

i also have trouble with the separate hue ambilight addon. how do i enable and disable it in a sequence? question to threadcreator as it seems he has some insights. 

i want ambilight feature on during short movies and trivia. then regular hue actions (low deep red for trailers) and lights of for main feature.

To dis-/enable the separate hue ambilight addon a cv action is needed in the sequence. You would create two seperate ones.
The first one would be a "hue ambilight addon off" after your short movies and trivia modules. Then a second one at the end of the sequence which turns the addon on again ("hue ambilight addon off").


Of courese your "kodi hue addon" has to be set to "ambilight" and not "theater" mode. But I assume thats a self-goer :)

But sadly up to now disabling the addon with a cv action from within the sequence didn't work for me as well. Wether it was due to some failure in my action (not sure if username and password of kodi-user has to be embedded to fulfill the http command) or it failed because the example actions from here had some failure.

Today I'm giving it a new try with the 0.0.47 addon and those updated cv actions ( here.). I'll update you once it's working and provide you with the action file.

Share this post


Link to post
Share on other sites
  • 0

 

Problem 2: It should be working with two consecutive Action Modules, but you shouldn't have to split up your actions like that. All you're doing is adding processing time. You can create one action file with any number of actions in it. I'd start there, and create an action file that first disables the Hue add-on, then sets whatever scene you want to set.

Did some testing now and everything works as it should. But only when adding two consecutive actions. If I put both orders (first disable hue plugin and then then add new light parameters) into one action file than cinemavision hangs/freezes/blackscreens.

This is how the 2in1 action looks:

# This CinemaVision Action file will disable a Kodi add-on by the add-on ID
# Replace <add-on id> with the correct ID for the add-on you want to disable
# An add-on ID will be similar to "script.cinemavision", or "script.kodi.hue.ambilight"
# Be sure that you have "Allow remote control via HTTP" enabled

http://<user>:<password>@<kodi-ip-adress>:8080/jsonrpc
{"jsonrpc": "2.0", "method": "Addons.SetAddonEnabled", "params": {"addonid": "script.kodi.hue.ambilight", "enabled":false}, "id": 1}

http://<hue-bridge-ip-adress>/api/<hue-bridge-user>/groups/1/action
PUT:{"on":true,"sat":255,"bri":250,"hue":45000,"alert":"lselect","transitiontime":20}

 

Edited by noiprocks
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

i also have trouble with the separate hue ambilight addon. how do i enable and disable it in a sequence? question to threadcreator as it seems he has some insights. 

i want ambilight feature on during short movies and trivia. then regular hue actions (low deep red for trailers) and lights of for main feature.

I've attached my working actions for you. As premise your hue ambilight addon should be activated under kodi addons.



Then just add those actions in the cinemavison sequence editor:

- "Disable_Hue-Addon.cvaction" after your trivia-module

- "Hue-TrailerLights.cvaction" before your trailer-module

- "Hue-FeatureLights.cvaction" before your feature-module

- "Enable_Hue-Addon.cvaction" at the end of your sequence



And in the general configuration of the cinemavison plugin->actions:

- "Enable_Hue-Addon.cvaction" as action for aborting a sequence

 

You will of course have to insert your data for the "<>"-parts inside the action-files to make this work in your environment.

Adjust the "sat","bri" and "hue" values inside the  Hue-TrailerLights.cvaction    to meet your desired low deep red color :)

Hue-FeatureLights.cvaction

Hue-TrailerLights.cvaction

Disable_Hue-Addon.cvaction

Enable_Hue-Addon.cvaction

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

cool. :)) will try this when i get home. cant wait to try it out. (enable disable ambilight addon)

ps . ther wouldnt be  a way to change between ambilight mode and theatre mode via a cvaction? prob to much but anyway. 

ill write again when ive tested it out. thx :))

Share this post


Link to post
Share on other sites
  • 0

ps . ther wouldnt be  a way to change between ambilight mode and theatre mode via a cvaction? prob to much but anyway. 

I guess thats not possible. At least as far as I know. Because disabling an addon globally via a cvaction is the one thing, but
changing settings within the addon via a cvaction might be one layer to deep ...

But don't worry. Even though that's not possible you can easily accomplish/workaround this with some clever positioned cvactions.

As I assume you like to maintain the "hue addons" behaviour to put on the lights when you press pause (->theater mode)?

If so, just add the attached cvaction
in the general configuration of the cinemavison plugin->actions as action for pausing a sequence.

By doing so (adjust the "hue" & "bri" settings inside the action to your liking), the lights softly dim up again, if you pause your main feature or trailers, etc.

Just write if something's unclear or you need a more detailed description.

Hue-Pause-Sequence.cvaction

Share this post


Link to post
Share on other sites
  • 0

I've attached my working actions for you. As premise your hue ambilight addon should be activated under kodi addons.



Then just add those actions in the cinemavison sequence editor:

- "Disable_Hue-Addon.cvaction" after your trivia-module

- "Hue-TrailerLights.cvaction" before your trailer-module

- "Hue-FeatureLights.cvaction" before your feature-module

- "Enable_Hue-Addon.cvaction" at the end of your sequence



And in the general configuration of the cinemavison plugin->actions:

- "Enable_Hue-Addon.cvaction" as action for aborting a sequence

 

You will of course have to insert your data for the "<>"-parts inside the action-files to make this work in your environment.

Adjust the "sat","bri" and "hue" values inside the  Hue-TrailerLights.cvaction    to meet your desired low deep red color :)

Hue-FeatureLights.cvaction

Hue-TrailerLights.cvaction

Disable_Hue-Addon.cvaction

Enable_Hue-Addon.cvaction

"enable hue addon" works

 

but "disable hue addon" dont works. the ambilights keep goin after two of tose files (disable) trailers (disable again) the main feature film.

 

how come disable hue addon script wont work? :/ really really annoying. any help here would be appriciated

Share this post


Link to post
Share on other sites
  • 0

"enable hue addon" works

 

but "disable hue addon" dont works. the ambilights keep goin after two of tose files (disable) trailers (disable again) the main feature film.

 

how come disable hue addon script wont work? :/ really really annoying. any help here would be appriciated

Did you make any modifications to the files? Could you post what you have in your Action file?

Share this post


Link to post
Share on other sites
  • 0

i did not make any modification on the "disable hue addon action file" its up this thread. 

 

you want me to upload that anyway?

No, but if you didn't modify the files that's probably why it's not working. :)

You have to input the IP address, username, and password for your Kodi machine, and make sure that Allow control via HTTP is enabled in your Kodi settings.

Share this post


Link to post
Share on other sites
  • 0

Ok. i dont think i have a kodi pass and user? i know my kodi ip adress tho (because i use yatse).

 

any ideas? can i skip putting in username and password? just put in the ip?

Ps i found under system info "device name = Kodi"  is that my username?

PS2

 

in kodi, under "internet acces"  should i check "use internet server"?

 

my username is Kodi and password is "empty" (blank)

how should the file look then?

Is this right? 

 

I know my IP adress for kodi

i know "user" is kodi

i know "password" is blank (there is no password) (see my file) shoulr that work? (see file)

 

User                             Pass

http://<kodi http-kodi>:<kodi http->

Enable_Hue-Addon.cvaction

Share this post


Link to post
Share on other sites
  • 0

ps. i have in the hue addon set "disable for short movies". is my file correct? does it matter that my hue addon has the "disable for short movies" checkmark?

Share this post


Link to post
Share on other sites
  • 0

Ok. i dont think i have a kodi pass and user? i know my kodi ip adress tho (because i use yatse).

Yes I would recommend setting up user and password as it's generally a safer solution. Just take a look at this under point 1 to find where to setup this.

in kodi, under "internet acces"  should i check "use internet server"?

I don't hink you have to enable this, as it's all taking place inside your local network.

 

my username is Kodi and password is "empty" (blank)

how should the file look then?

Is this right? 

no thats not right. i recommend setting up a username and password like mentioned above. If you do so, your final action for deactivating the addon would look like this: (change the "<>"-parts with your data)


http://<kodi-http_username>:<kodi_http_password>@<kodi_ip-address>:8080/jsonrpc
{"jsonrpc": "2.0", "method": "Addons.SetAddonEnabled", "params": {"addonid": "script.kodi.hue.ambilight", "enabled":false}, "id": 1}

and the action for activating the addon would be this:


http://<kodi-http_username>:<kodi_http_password>@<kodi_ip-address>:8080/jsonrpc
{"jsonrpc": "2.0", "method": "Addons.SetAddonEnabled", "params": {"addonid": "script.kodi.hue.ambilight", "enabled":true}, "id": 1}

 

If you setup your files like mentioned above it will work. I can guarantee it based on my own doing :)

 

ps. i have in the hue addon set "disable for short movies". is my file correct? does it matter that my hue addon has the "disable for short movies" checkmark?

Generally speaking this shouldn't matter at all or interfer with your cinemavison actions as they globally deactivate the addon regardless of what kind of movie (short or full feature) you play.

 

I hope this helps to get your setup rolling. Feel free to write again if you get stuck.

 

 

Share this post


Link to post
Share on other sites
  • 0

ok so i basicly need a pass for it to work :P ah well ill try it tomorrow then and report back. thx :) plz check here tomorrow again

Yeah, I guess the incomplete user/password might be the problem as it leads to problems for authenticing  the en-/disable order in the action.

I'll check in tomorrow again ;)

Share this post


Link to post
Share on other sites
  • 0

Okey. so in the action file it says

 

http://<kodi http-kodi>:<kodi http-kodi>@<192.168.1.3>:8080/jsonrpc

 

"if" my username is "user" and my pass is "Kodi" should the string look like this?

http://<kodi http-user>:<kodi http-Kodi>@<192.168.1.3>:8080/jsonrpc  

 

?

Well i try it that way and cinemavision crashes :/

Share this post


Link to post
Share on other sites
  • 0

plz put a "fake username" and a "fake pawwsord" and  a fake ip number and port so i know exactly how my file should look :) ?

 

say i have 192.168.1.9  and user Kodi pass KODI port 99  <........ example. then how exaclty should the file look? :)

because in the example above ther is mixups on when and if to use "_ " instead of " - "  and if i really should use spaces "  "   ?

Share this post


Link to post
Share on other sites
  • 0

plz put a "fake username" and a "fake pawwsord" and  a fake ip number and port so i know exactly how my file should look :) ?

 

say i have 192.168.1.9  and user Kodi pass KODI port 99  <........ example. then how exaclty should the file look? :)

because in the example above ther is mixups on when and if to use "_ " instead of " - "  and if i really should use spaces "  "   ?

Okay then this would look like this e.g. for disabling:

http://Kodi:KODI@192.168.1.9:99/jsonrpc
{"jsonrpc": "2.0", "method": "Addons.SetAddonEnabled", "params": {"addonid": "script.kodi.hue.ambilight", "enabled":false}, "id": 1}

I've additionally attached the action files with your given "fake data". Those can be easily edited by you.
And just as sidenote: I'd recommend not changing the port from default 8080 to something else. At least in my scenario that's the only one where everything worked.

Disable_HueAddon-Rippmaster.cvaction

Enable_HueAddon-Rippmaster.cvaction

Share this post


Link to post
Share on other sites
  • 0

thx good lord :)  ill try directly.

 

Could anything else crash if i switch from 80 to 8080? could there be problems with the app yatsee or any other problem follow if i switch from port 80 to 8080?

Share this post


Link to post
Share on other sites
  • 0

You are welcome :)

I don't think anything might crash if you change it from default 8080, but I don't See why you should...

But as i use yatse myself, i can tell you that you can edit the port in its settings if you want to change the port within kodi for some reason.

Share this post


Link to post
Share on other sites
  • 0

OK so ive tryed both port 80 and 8080 and in both cases the ambilight just wont turn off.

 

i also have regular cv actions (blue , red , and so on  after the "ambilight addon is disabled" if that can disturb?

or is my problem something else?  :/

i have not uppdated my hue addon , (readin alot of ppl got problems with the latest update). would updating the hue addon be good maby?=

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

About Us

CinemaVision began in 2014 as a collaboration to create content for use with your home theater, offering movie trivia slides and video bumpers. It has since grown to be THE PREMIER WAY to create and customize your preshow experience. Download the CinemaVision add-on for Kodi today from the official Kodi repository, and easily create a sequence of trivia, videos, trailers, home automation triggers and more that will bring the experience of a movie theater straight to your screen!

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines and Terms of Use.